Module 16: The Siebel Data Model


	Lab 16-1
	Exploring the Data Model

	Objective: To examine some of the tables, indexes, user keys, and foreign keys that make up the Siebel Data Model.
	 30-40 minutes


Instructions:

In this lab, you will investigate the Siebel Data Model to gain a better understanding of the relationships between the user interface, business and data layers. First, you will navigate Tools to determine how a user interface object references an object in the business layer and how that object references an object in the data layer. Next, you will explore Tools and gain a better understanding of various table properties, system columns, user keys and indexes for a table. You will then review the different extension tables and their parent/base tables.

1. First, you will identify some of the major application architecture objects being used for the Contact Screen. You will determine the data table and column that maps to the UI Contact First Name list column in the Contact List Applet. To assist with this task, you will use the job aid, below. Enter your responses into the job aid, as directed.

	Layer
	Step
	Object you are looking For
	Tip for Finding Information
	Enter Value Here

	User

Interface

Objects


	1
	Display Name
	Look for text label

· List Applet: Column heading above field in question

· Form Applet: Control label next to field


	

	
	2
	Applet Name
	In UI: Help > About View
	

	Business Objects
	3
	Business Component
	In UI: Help > About View
	

	
	4
	Business Component Field
	In Tools

a. <Applet name> | List :: List |

List Column.

b. Query Display Name for <display

name>.

c. Value you need is the Field property
	

	Data Objects
	5
	Table Name
	In Tools: Business Component :: <BC name>| Field :: <field name>

IF Join property is empty Enter base table name ELSE Enter value in Join property

Note: If query fails, Field property is calculated. Try this: query Calculated

Value for *<field name>*
	

	
	6
	Table Column Name
	In Tools: Business Component :: <BC

name>| Field :: <field name>. Value in

Column property.
	


2. The objects you identified in an earlier lab are already completed for you in the diagram, below. The diagram illustrates how a list column in an applet uses data in a table column. The Contact business component references a base table, which in turn contains many columns. One of these columns contains data referenced by a business component field called First Name. This field, in turn, is referenced by the applet’s list column, and the data is displayed. 

Refer to the job aid completed in the previous step to complete the values in the empty boxes.








3. In this step, you will inspect some important table properties, such as Required, Physical Type, Length and Default for columns in the S_CONTACT table. Objects at the data layer are also represented in the OE as object types with their definitions displayed in the OBLE.

a. Select Table :: S_CONTACT | Column. Most table columns in Siebel applications are data columns. Sometimes called base columns, data columns provide the data for fields, or serve as foreign keys that point to rows in other tables. You cannot modify the properties of data columns.

b. Examine the Type property.

i. To simplify viewing, lock the Name property column in place by double-clicking the Name property column heading.

ii. Scroll to the Type property and note that the Name property remains in place. What two column types are included in this table?


c. Review the system columns that are representative of the columns that appear in all tables.

i. Right-click anywhere in the lower window of the OBLE.

ii. Click Sort Order.

iii. Sort by Type, descending.

iv. Of these system columns, which one is the primary key for this table? For assistance, view the Primary Key property.


d. Query the Required property for True (i.e the property value should be checked). Is MODIFICATION_NUM a required column?

i. Yes.

ii. No.

e. Review the Physical Type and Length properties. There are several options for physical type and length.

i. From the Tools application-level menu, select View > Windows > Properties Window to open the Properties Window.

ii. Click the pushpin to auto-hide the properties window.
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iii. Query the table for all columns that have Physical Type of Date Time. What column in S_CONTACT has a Physical Type of Date Time?


4. In this step, you will examine how user keys can enforce uniqueness when records are created. The user key is a column or set of columns on a Siebel table that uniquely identifies a row. This is in addition to the ROW_ID column, which is also unique. We will see how the two columns displayed under User Key Columns make up the S_OPTY_U1 user key.

a. Expose the User Key Column in Object Explorer.

i. Select View > Options > Object Explorer.

ii. Scroll down to Table and expand the Table object type.

iii. Expand the User Key object type and ensure User Key Column has a checkmark.

iv. Click OK.

b. Select Table :: S_OPTY | User Key to display the user keys for the table. When querying for S_OPTY, ensure you query the Name property, not the Base Table property. Which user keys are defined?


c. Select Table :: S_OPTY | User Key :: S_OPTY_U1 | User Key Column. Identify which columns make up this user key. Enter your answer directly into the diagram, below.

	S_OPTY

	ROW_ID
	
	
	



d. Log out of your current Call Center session.

e. Double-click on the Siebel Call Center shortcut on the desktop. Login as SADMIN/SADMIN connecting to Sample database.
f. Navigate to Opportunities > My Opportunities.

g. Create a new opportunity record using the values in the table, below. 
	Property
	Value

	Opportunity Name 
	User Key Verification

	Account
	South Huron Hosp


h. Create another new record with exactly the same values. Save it. What happens? Why?


You should have received an error message similar to this:
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i. Click OK to dismiss the warning.

j. Now, change Opportunity Name to User Key Test2. You should be able to now step off the record and save it since both records are unique.

k. Delete the record.

l. Log out of the Call Center application.

5. In this step, you will use Siebel Tools to examine indices. Index object definitions are metadata representations of physical indices in the underlying database management system. Siebel applications include a set of standard indices.

a. Select Table :: S_OPTY | Index to display the indexes for the table. How many indices are defined for the S_OPTY table?

i. More than 10.

ii. More than 40.

b. Select Table :: S_OPTY | Index :: S_OPTY_P1 | Index Column. Which column(s) make up this index?


c. Which column(s) make up the S_OPTY_U1 index?


6. In this step, you will practice locating foreign key columns. You will use this skill while exploring the Siebel Data Model and in configuring the Siebel application.

a. Select Table :: S_SRV_REQ | Column to display the columns in the S_SRV_REQ table.

b. What is the Foreign Key Table for the ACT_ID column? 





c. Query the Foreign Key Table property for S_PROD_INT. What column(s) serve(s) as a foreign key to S_PROD_INT? Draw line(s) between the tables to indicate FK/PK relationship(s).


7. In this step, you will examine a 1:1 extension table to see how it relates to its base table. Base tables and extension tables maintain a primary key / foreign key relationship. Extension tables have a foreign key that references the primary key of its base table.

a. Select Table :: S_SRV_REQ_X.

b. View the Type property. What is the type of the table?


c. What is the Base Table to S_SRV_REQ_X?


d. What is the value of the foreign key Column Name for the foreign key to S_SRV_REQ in the S_SRV_REQ_X extension table?


e. Select Table :: S_SRV_REQ_X | Column :: PAR_ROW_ID.

8. In this step, you will identify any pre-built intersection tables that support the M:M relationship between project and contacts. The query below works by selecting tables with foreign keys for either S_OPTY or S_CONTACT.

a. Select the Flat tab and then select Column in the Object Explorer (OE).

b. Use Columns Displayed in the OBLE to move the Parent Table, Name, Foreign Key Table, and User Key Sequence columns to the left side of the OBLE.

c. Execute a compound query with the following values:

	Property
	Value

	User Key Sequence
	1 or 2

	Foreign Key Table
	S_OPTY or S_CONTACT


d. Sort the results of the query in ascending order for both the Parent Table list column and the User Key Sequence list column.

e. Right-click in the OBLE and select Sort Order.

f. In the Sort Order dialog box select the Sort by field.

g. Select Parent Table from the drop-down list.

h. In the Then by field click the drop-down arrow and select User Key Sequence.

i. Accept the default Ascending for both fields.

j. Click OK.

k.  Look for a Parent Table that appears in two adjacent rows where the Foreign Key table property is S_OPTY in one row and S_CONTACT in the other row. Note that the parent table name has a _CON suffix. Which table satisfies these criteria?


l.   Complete the diagram, below.


i.    Enter the names of the two data tables that have a M:M relationship.

ii.   Enter the name of the intersection table.

iii.  Enter the names of the two FK columns in the intersection table.







Solutions Lab 16-1 Exploring the Data Model


1.

	Layer
	Step
	Object you are looking For
	Tip for Finding Information
	Enter Value Here

	User

Interface

Objects


	1
	Display Name
	Look for text label

· List Applet: Column heading above field in question

· Form Applet: Control label next to field


	First Name

	
	2
	Applet Name
	In UI: Help > About View
	Contact List Applet / Contact Form Applet

	Business Objects
	3
	Business Component
	In UI: Help > About View
	Contact

	
	4
	Business Component Field
	In Tools

a. <Applet name> | List :: List |

List Column.

b. Query Display Name for <display

name>.

c. Value you need is the Field property
	First Name

	Data Objects
	5
	Table Name
	In Tools: Business Component :: <BC name>| Field :: <field name>

IF Join property is empty Enter base table name ELSE Enter value in Join property

Note: if query fails, Field property is calculated. Try this: query Calculated

Value for *<field name>*
	S_CONTACT

	
	6
	Table Column Name
	In Tools: Business Component :: <BC

name>| Field :: <field name>. Value in

Column property.
	FST_NAME


2.










3.b.ii  Data(Public) and System

3.c.iv  ROW_ID.

3.d. Yes

3.e.iii  CUST_SINCE_DT

4.b S_OPTY_II, S_OPTY_U1.

4.c

	S_OPTY

	ROW_ID
	BU_ID
	NAME
	PR_DEPT_OU_ID


4.h The new record cannot be saved because a record with the same name, account, and organization already exists. If all three fields are identical, that is, the user key matches, the save are disallowed.

5.a. More than 40

5.b. ROW_ID.

5.c. BU_ID, CONFLICT_ID, NAME, PR_DEPT_OU_ID

6.b. 





6.c. 






7.b  Extension.

7.c. S_SRV_REQ.

7.d. PAR_ROW_ID.
8.k. S_OPTY_CON.

8.l. 
List Column or Control:





Applet: Contact List Applet





View: Visible Contact List View





Screen: Contacts Screen





Business Object: Contact





Business Component: Contact





Field:





User Key





Table:





Column:





PK





FK





ROW_ID











ROW_ID























?          





ROW_ID

















ACT_ID





S_SRV_REQ

















 S_PROD_INT          





ROW_ID























 S_SRV_REQ          





Data Table





Intersection Table





Data Table





PK





PK





FK





FK





ROW_ID





























ROW_ID























 S_CONTACT          





ROW_ID























 S_OPTY          





Screen: Contacts Screen





View: Visible Contact List View





Applet: Contact List Applet





List Column or Control: 


First Name





Business Component: Contact





Field: 


First Name





Business Object: Contact





Column:


FST_NAME





Table:


S_CONTACT





FK





PK





ROW_ID

















ACT_ID





ROW_ID























S_EVT_ACT          





S_SRV_REQ





 S_PROD_INT          























ROW_ID





 S_SRV_REQ          





PRDINT_ID





SP_PRDINT_ID











ROW_ID





PK





FK

















 S_OPTY          





S_OPTY_CON











ROW_ID











FK





FK





ROW_ID





OPTY_ID





CON_ID





 S_CONTACT          





ROW_ID























Data Table





Intersection Table





Data Table





PK





PK
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